× Die Bosch D-Jetronic war 1967 die erste Großserien elektronische Einspritzung der Welt. - Bosch's D-Jetronic was the first mass-production electronic fuel injection.

280SE 3.5 Low Power When Acceleration

  • Jazzenco81
  • Topic Author
  • Offline
  • New Member
  • New Member
  • Mercedes-Benz W108 280 SE/L 3.5
More
19 May 2020 22:56 #13940 by Jazzenco81 Mercedes-Benz W108 280 SE/L 3.5
280SE 3.5 Low Power When Acceleration was created by Jazzenco81
Hello Everybody,
First of all thank you very much for my registration confirmation and creating such a perfect site where you can find detailed information about djetronic and Kjetronic systems.

I have w108 280SE 3.5. I finished full restoration recently including m116.980 djetronic engine.
We have this car almost 30 years and I know the acceleration in early times and how power decreased over time due to some compression issues. All in all, I renewed most of the engine parts with new std 92mm pistons..

I entered dyno test and results were not satisfactory. Engine has 147 kw but my results were 115 kw.
My cylinder compressions are, all around 12 bar.
Djetronic equipments,
0280100012 MAP sensor I measered electric values Primary winding 90 ohm secondary 355ohm. It's holding vacuum.

I have 2 more spares. One new. But I think even I have one 0280100012 new in bıox original settings cganging over time I guess. Because when I replaced with existing MAP sensor on car with new one. Car misfires like it gives wrong signals to ecu for injector pulsing,

I have new trigger points.
Igginition timing is 3 Degrees ATDC at 850rpm idle.
Timming is correct, cranckshaft 0, cams and distributor drive are aligned.
Throttle switch is ok. Pulses 20 times full throttle.
New distributor with cap and rotor.
Valve settings are ok.

Problem is when accelerating from 0. Looks like engine or transmission does not give enough power. Car does not have any misfire or hesitation but I compare with past times, Acceleration was better, spinning at half throttle. But now looks like weaker. Also acceleration when kickdown 4-3 around 100km/h also not satisfactory. Feeling about 25-30HP missing.

Any suggestion what can be the reason? Transmission can be the reason? Or any ideas?

Sorry for detaied explanation.

Thank you very much in advance.

Regards,
Kutluhan

Please Log in or Create an account to join the conversation.

  • Volker
  • Volker's Avatar
  • Offline
  • Moderator
  • Moderator
  • Europe
  • Mercedes-Benz R107 450 SL, Mercedes-Benz W111 280 SE Cabrio
  • Dr-DJet repariert und sammelt alles! :-)
More
20 May 2020 00:05 #13941 by Volker Europe Mercedes-Benz R107 450 SL, Mercedes-Benz W111 280 SE Cabrio
Replied by Volker on topic 280SE 3.5 Low Power When Acceleration
Merhaba Kutluhan,

if you have various 0 280 100 012 MAP sensors and they all give different results, something is wrong with them. Unfortunately new ones from 80s and later can be wrongly tuned as well. Especially the last ones from 2000+ are a catastrophy. FD no on upper right rivet tells you what manufacturing date was. Istanbulda bir arkdasim var. O 350 SLC kulaniyor, adi Juan. O Boschtan bir MAP sensör aldi. Juan Yeniköyde oturuyormus. Onun username RSADUT. Maybe you can use his MAP sensor for a try.

I also saw that he had some mechanic repair his ECU and that seems to have been felaket - a catastrophy. Try to contact Juan and maybe he will help you. That is my best advice from far away. Ah Istanbul - seni özledim.

Viele Schraubergrüße - best regards, Dr-DJet Volker
Alles über den Mercedes-Benz 107 SL/C in Sternzeit-107.de

This image is hidden for guests.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

Time to create page: 0.037 seconds
Powered by Kunena Forum